<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

<html>
<head>
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
	<title>The Baltic Course | Baltic States news & analytics</title>

	<meta property="og:title" content="" />
	<meta property="og:type" content="article" />
	<meta property="og:url" content="://www.baltic-course.com/eng/help/rss/:/www.baltic-course.com/eng/good_for_business/?doc=161624" />
	<meta property="og:image" content="://www.baltic-course.com/images/baltic_course_240.png" />
	<meta property="og:description" content="" />
	<meta property="og:site_name" content="The Baltic Course | Baltic States news &amp; analytics" />

	<meta property="fb:admins" content="1369770601" />
	<meta property="fb:app_id" content="479098385443722" />

	<META name="author" content="The Baltic Course - Балтийский курс" />

	<META name="robots" content="index,follow" />
	<META name="copyright" content="Copyright © 1996 — 2010 The Baltic Course, All Rights Reserved" />

	<META name="keywords" content="good for business, investments, latvia, markets and companies, woodwork, riga, daugavpils, liepaja, ventspils, bono, billion, jānis, upenieks, timber, million, sawn, reach, investments, board, member, aims, euro, market, plans, turnover, amount, attract" />
	<META name="description" content="The LLC (SIA) BONO enters the sawn timber market and plans to attract investments in the amount of 100 million euro to reach 1 billion turnover within 3 years. BONO’s team consists of 83 professionals of the industry with vast experience in the wood trade, experienced logistics experts, financiers, lawyers and information technology engineers, and marketing specialists." />
	<meta name="medium" content="news" />
	<link rel="alternate" href="http://www.baltic-course.com/rus/" hreflang="ru" />
	<link rel="STYLESHEET" type="text/css" href="/css/main.css">
	<LINK REV="made" HREF="mailto:dmitrijs@mansbirojs.lv">

	<script src="/js/banner.js" type="text/javascript"></script>
	<script src="/js/tools.js" type="text/javascript"></script>
	<script src="/js/main.js" type="text/javascript"></script>

	
	<link rel="alternate" type="application/rss+xml" title="RSS" href="://www.baltic-course.com/eng/help/news_ml/">
	<script async src='https://www.google-analytics.com/analytics.js'></script>
<script>
	window.ga = window.ga || function (){(ga.q=ga.q||[]).push(arguments)};
	ga.l = +new Date;
	ga('create', 'UA-642996-33', 'auto');
	ga('send', 'pageview');
</script>
<meta name="google-site-verification" content="YR-Z1yKDP7JYMYrYW2SsyAL4GQiVxwlYMOsab0_E0DU" />	<link rel="apple-touch-icon" sizes="180x180" href="/favicons/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicons/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicons/favicon-16x16.png">
<link rel="manifest" href="/favicons/site.webmanifest">
<link rel="mask-icon" href="/favicons/safari-pinned-tab.svg" color="#5bbad5">
<link rel="shortcut icon" href="/favicons/favicon.ico">
<meta name="msapplication-TileColor" content="#da532c">
<meta name="msapplication-config" content="/favicons/browserconfig.xml">
<meta name="theme-color" content="#ffffff"></head>
<!-- index -->
<body onload="init();"><a name="pagetop" id="pagetop"></a>
<div id="center">
	<div style="padding-left: 209px;"><div id="main"><h1>The Baltic Course</h1>
<div id="content">
<div class="newsbox">
	<h4>
		<b>International Internet Magazine. Baltic States news & analytics</b>
		<span>Friday, 28.01.2022, 20:52</span><br clear="all"></h4>
	<div class="body">
		<div class="first"><a href="/eng/good_for_business/?doc=161624" title="BONO aims at a billion!"><img  title="BONO aims at a billion!" alt="BONO aims at a billion!" src="images/text/medium/2022-01/220128_janis2.jpg" height="145" width="240" alt="" title="" border="0"></a><h2><a href="/eng/good_for_business/?doc=161624" title="BONO aims at a billion!">BONO aims at a billion!</a></h2><span>28.01.2022.</span><p>The LLC (SIA) BONO enters the sawn timber market and plans to attract investments in the amount of 100 million euro to reach 1 billion turnover within 3 years.</p><h5><b>Keyword tags:</b> <a href="/eng/good_for_business/?name=Good+for+Business&amp;key=162" title="Good for Business">Good for Business</a>, <a href="/eng/investments/?name=Investments&amp;key=3" title="Investments">Investments</a>, <a href="/eng/?name=Latvia&amp;key=26" title="Latvia">Latvia</a>, <a href="/eng/markets_and_companies/?name=Markets+and+Companies&amp;key=41" title="Markets and Companies">Markets and Companies</a>, <a href="/eng/?name=Woodwork&amp;key=139" title="Woodwork">Woodwork</a></h5></div>
		<div class="rest"><h3><a href="/eng/baltic_states/?doc=161622" title="LLC Dizozols Investments finalizes investment attraction deal with Crowdestor with record-high profits"><img  title="LLC Dizozols Investments finalizes investment attraction deal with Crowdestor with record-high profits" alt="LLC Dizozols Investments finalizes investment attraction deal with Crowdestor with record-high profits" src="images/text/small/2021-08/210826_diz.jpg" height="85" width="100" alt="" title="" border="0"><br><span>26.08.2021.</span><u>LLC Dizozols Investments finalizes investment attraction deal with Crowdestor with record-high profits</u></a></h3><h3><a href="/eng/good_for_business/?doc=161599" title="On the verge of its 25th anniversary, The Baltic Course leaves business media market"><img  title="On the verge of its 25th anniversary, The Baltic Course leaves business media market" alt="On the verge of its 25th anniversary, The Baltic Course leaves business media market" src="images/text/small/2020-12/201218_kolonka.JPG" height="77" width="113" alt="" title="" border="0"><br><span>30.12.2020.</span><u>On the verge of its 25th anniversary, The Baltic Course leaves business media market</u></a></h3><h3><a href="/eng/good_for_business/?doc=161595" title="EU to buy additional 100 mln doses of coronavirus vaccine"><span>30.12.2020.</span><u>EU to buy additional 100 mln doses of coronavirus vaccine</u></a></h3><h3><a href="/eng/tourism/?doc=161594" title="Hotels showing strong interest in providing self-isolation service"><span>30.12.2020.</span><u>Hotels showing strong interest in providing self-isolation service</u></a></h3><h3><a href="/eng/analytics/?doc=161587" title="Latvia to impose curfew, state of emergency to be extended until February 7"><span>29.12.2020.</span><u>Latvia to impose curfew, state of emergency to be extended until February 7</u></a></h3><h3><a href="/eng/good_for_business/?doc=161582" title="Number of new companies registered in Estonia up in 2020"><span>29.12.2020.</span><u>Number of new companies registered in Estonia up in 2020</u></a></h3><h3><a href="/eng/legislation/?doc=161581" title="Lithuanian president signs 2021 budget bill into law"><span>29.12.2020.</span><u>Lithuanian president signs 2021 budget bill into law</u></a></h3></div><br clear="all">
	</div><br clear="all">
</div><div class="ad728">
<script type="text/javascript"><!--
google_ad_client = "ca-pub-3579843345222595";
/* New_firstpage */
google_ad_slot = "2060982041";
google_ad_width = 728;
google_ad_height = 90;
//-->
</script>
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script></div>
<div class="archive">
<h4>Read also</h4>
<ul><li><i>28.12.2020</i><a href="/eng/good_for_business/?doc=161580" title="Tartu to support students' solar car project">Tartu to support students' solar car project</a></li><li><i>28.12.2020</i><a href="/eng/energy/?doc=161579" title=""></a></li><li><i>28.12.2020</i><a href="/eng/baltic_states/?doc=161575" title="First people in Latvia receive Covid-19 vaccines">First people in Latvia receive Covid-19 vaccines</a></li><li><i>28.12.2020</i><a href="/eng/finances/?doc=161593" title="New Year Cards and Calendars of Rietumu Bank presented">New Year Cards and Calendars of Rietumu Bank presented</a></li><li><i>28.12.2020</i><a href="/eng/good_for_business/?doc=161576" title="Owner of Kunda Nordic Tsement to install full-scale CCS facility in Norway">Owner of Kunda Nordic Tsement to install full-scale CCS facility in Norway</a></li><li><i>23.12.2020</i><a href="/eng/baltic_states/?doc=161568" title="airBaltic to conduct repatriation flight from UK on December 28">airBaltic to conduct repatriation flight from UK on December 28</a></li><li><i>23.12.2020</i><a href="/eng/good_for_business/?doc=161569" title="Flying Forward 2020 starts developing air mobility of cities">Flying Forward 2020 starts developing air mobility of cities</a></li><li><i>23.12.2020</i><a href="/eng/good_for_business/?doc=161564" title="LTG Infra gets green light to build Rail Baltica section from Kaunas to Latvian border">LTG Infra gets green light to build Rail Baltica section from Kaunas to Latvian border</a></li><li class="adv"><table cellpadding="0" cellspacing="0" border="0">
                   	<tr valign="top"><td><a  class="long" target="_blank" title="Jobble" href="https://uk.jooble.org/jobs-business-developer"><img  src="images/images/cross/200320_jobble.png" height="60" width="468" alt="" title="" border="0"></a></td></tr>
				</table></li><li><i>23.12.2020</i><a href="/eng/markets_and_companies/?doc=161563" title="Lidl Lithuania to destroy Salmonella-contaminated eggs from Ukraine">Lidl Lithuania to destroy Salmonella-contaminated eggs from Ukraine</a></li><li><i>23.12.2020</i><a href="/eng/legislation/?doc=161565" title="New Year's fireworks banned in Latvia">New Year's fireworks banned in Latvia</a></li><li><i>23.12.2020</i><a href="/eng/legislation/?doc=161562" title="Face masks to be mandatory also in nature trails in Latvia">Face masks to be mandatory also in nature trails in Latvia</a></li><li><i>22.12.2020</i><a href="/eng/good_for_business/?doc=161556" title="In 2019, household disposable income in Latvia increased by 6.8%">In 2019, household disposable income in Latvia increased by 6.8%</a></li><li><i>22.12.2020</i><a href="/eng/legislation/?doc=161555" title="Initially, 4,875 medics to be vaccinated against Covid-19 in Latvia">Initially, 4,875 medics to be vaccinated against Covid-19 in Latvia</a></li><li><i>22.12.2020</i><a href="/eng/good_for_business/?doc=161550" title="The vaccination against Covid-19 in Latvia will start on December 28">The vaccination against Covid-19 in Latvia will start on December 28</a></li><li><i>22.12.2020</i><a href="/eng/forums/?doc=161592" title="The photo exhibition “Icons – an Exhibition about the Right to Exist” opened in Rietumu in Riga">The photo exhibition “Icons – an Exhibition about the Right to Exist” opened in Rietumu in Riga</a></li><li><i>22.12.2020</i><a href="/eng/transport/?doc=161552" title="Movement of parcels between Estonia, UK suspended until New Year; Lithuanian Post warns of delays">Movement of parcels between Estonia, UK suspended until New Year; Lithuanian Post warns of delays</a></li></ul>
</div><div class="ad728">
<script type="text/javascript"><!--
google_ad_client = "ca-pub-3579843345222595";
/* New_firstpage */
google_ad_slot = "2060982041";
google_ad_width = 728;
google_ad_height = 90;
//-->
</script>
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script></div></div>
</div></div>
	<div id="left">
	<div style="padding: 0 3px 0 5px;">
		<a href="/eng/"><img src="images/baltic_course.png" width="200"
																		height="192" alt="" border="0"></a>
		<div class="hotkeys"><a title="Search site" href="/eng/help/search_site/"><img  src="images/cross/icon-glass.gif" height="20" width="32" alt="" title="" border="0"></a><a title="Site map" href="/eng/help/site_map/"><img  src="images/cross/icon-map.gif" height="20" width="32" alt="" title="" border="0"></a><a title="Mail us" href="/eng/help/mail_us/"><img  src="images/cross/icon-message.gif" height="20" width="32" alt="" title="" border="0"></a></div>		<div class="langswitch"><a href="/rus/">Русский</a></div>		<div id="nav1"><a title="COVID-19" href="/eng/covid-19/" >COVID-19</a><a title="Good for Business" href="/eng/good_for_business/" >Good for Business</a><a title="Modern EU" href="/eng/modern_eu/" >Modern EU</a><a title="Analytics" href="/eng/analytics/" >Analytics</a><a title="Investments" href="/eng/investments/" >Investments</a><a title="Transport" href="/eng/transport/" >Transport</a><a title="Energy" href="/eng/energy/" >Energy</a><a title="Real Estate" href="/eng/real_estate/" >Real Estate</a><a title="Financial Services" href="/eng/finances/" >Financial Services</a><a title="Technology" href="/eng/Technology/" >Technology</a><a title="Markets and Companies" href="/eng/markets_and_companies/" >Markets and Companies</a><a title="Baltic export" href="/eng/baltic_export/" >Baltic export</a><a title="Tourism" href="/eng/tourism/" >Tourism</a><a title="Legal Counsel" href="/eng/legal_counsel/" >Legal Counsel</a><a title="EU – Baltic States" href="/eng/baltic_states/" >EU – Baltic States</a><a title="Baltic States – CIS" href="/eng/baltic_states_cis/" >Baltic States – CIS</a><a title="Legislation" href="/eng/legislation/" >Legislation</a><a title="Direct speech" href="/eng/direct_speech/" >Direct speech</a><a title="Round Table" href="/eng/round_table/" >Round Table</a><a title="Education and Science" href="/eng/education/" >Education and Science</a><a title="Forums" href="/eng/forums/" >Forums</a><a title="Book review" href="/eng/book_review/" >Book review</a><a title="Archive" href="../../archive/eng" >Archive</a><a title="Tulenev’s Art Studio" href="/eng/tjulenevs_art_studio/" >Tulenev’s Art Studio</a></div>
		<SCRIPT LANGUAGE="JavaScript" TYPE="text/javascript">
<!--
function clearField($this) {
	if ($this.value == $this.title) {
		$this.className	= "edit";
		$this.value 	= '';
	}
}

function restoreField($this) {
	$this.value	= trimString($this.value);
	if (!$this.value) {
		$this.className	= "";
		$this.value 	= $this.title;
	}
}

function trimString (str) {
  while (str.charAt(0) == ' ')  str = str.substring(1);
  while (str.charAt(str.length - 1) == ' ')  str = str.substring(0, str.length - 1);
  return str;
}

function doSubmit($this) {
	if ($this.value == $this.title) {
		$this.value = '';
	}
}
//-->
</SCRIPT>
<form id="fQS" name="fQS" action="/eng/help/search_site/" method="get">
	<b>Search site</b>
	<input title="enter keyword" onfocus="clearField(this)" onblur="restoreField(this)" type="Text" value="enter keyword" name="qs" id="qs"><input type="Submit" value="" onclick="doSubmit(document.getElementById('qs'))" id="qsb" name="qsb">
</form>
		<div style="overflow: hidden;">
			<div style="padding:20px 0; margin: -1px -10px;">
				<div class="fb-page" data-href="https://www.facebook.com/BalticCoursecom/" data-height="370"
					 data-small-header="true" data-adapt-container-width="true" data-hide-cover="true"
					 data-show-facepile="true">
					<blockquote cite="https://www.facebook.com/BalticCoursecom/" class="fb-xfbml-parse-ignore"><a
								href="https://www.facebook.com/BalticCoursecom/">baltic-course.com</a></blockquote>
				</div>
			</div>
		</div>

		<div id="bannerleft"><div><a  target="_blank" title="DEC" href="http://www.dec.lv/index.php"><img  src="images/images/cross/DEC.png" height="60" width="120" alt="" title="" border="0"></a></div><div><a  target="_blank" title="hatay escort" href="http://www.hatayescortx.xyz"><img  src="images/images/cross/ExportBaltic_bann.jpg" height="123" width="202" alt="" title="" border="0"></a></div><div><a  target="_blank" title="Russian_Language_School_BIA" href="http://www.rls.bsa.edu.lv/index.php?lang=en"><img  src="images/images/cross/Russian_Language_School_BIA.jpg" height="75" width="100" alt="" title="" border="0"></a></div><div><a  target="_blank" title="Lagonaki" href="http://www.lagonaki.com"><img  src="images/images/cross/lagonaki_en.jpg" height="60" width="120" alt="" title="" border="0"></a></div><div><a  target="_blank" title="iskenderun escort" href="http://www.iskenderunrehber.net"><img  src="images/images/cross/hair.jpg" height="60" width="120" alt="" title="" border="0"></a></div></div>	</div>
</div>
</div>
<div id="right">
	<div style="padding: 0 5px 0 3px;">
		<div id="bannertopright"><a  target="_blank" title="Internatinal Round Table" href="http://www.baltic-course.com/round-tables-2016/index.html"><img  src="images/images/cross/banner-eng1-new-BSA1.gif" height="150" width="172" alt="" title="" border="0"></a><a  target="_blank" title="Covid " href="https://spkc.gov.lv/en/news/get/nid/530"><img  src="images/images/cross/200323_covidENG.jpg" height="60" width="120" alt="" title="" border="0"></a></div>		<div class="newsline">
	<h4><a href="/eng/baltic_news/" title="Other events in Baltic States">Other events in Baltic States</a></h4>
	<div class="body"><h3><a href="/eng/baltic_news/?doc=21854" title="Porzingis back at full practices with Mavericks"><img  src="images/text/small/2020-12/porz.jpg" height="85" width="102" alt="" title="" border="0"><span>30.12.2020</span> <u>Porzingis back at full practices with Mavericks</u></a></h3><h3><a href="/eng/baltic_news/?doc=21852" title="Kurucs scores three points in season opener as Nets defeat Warriors"><span>23.12.2020</span> <u>Kurucs scores three points in season opener as Nets defeat Warriors</u></a></h3><h3><a href="/eng/baltic_news/?doc=21851" title="Dinamo lose to Sochi in OT"><span>22.12.2020</span> <u>Dinamo lose to Sochi in OT</u></a></h3><h3><a href="/eng/baltic_news/?doc=21848" title="3x3 basketball team Riga places first at World Tour Final"><span>21.12.2020</span> <u>3x3 basketball team Riga places first at World Tour Final</u></a></h3><h3><a href="/eng/baltic_news/?doc=21846" title="M.Dukurs triumphs in season's 4th Skeleton WC stage"><span>18.12.2020</span> <u>M.Dukurs triumphs in season's 4th Skeleton WC stage</u></a></h3></div>
</div>		<div class="editor">
	<h4><a href="/eng/editors_note/" title="Editor's note">Editor's note</a></h4>
	<div class="intro"><a href="/eng/editors_note/?doc=21857" title="«The Baltic Course» Is Sold and Stays in Business!"><img  align="left" src="images/text/small/2021-06/210608.jpg" height="85" width="113" alt="" title="" border="0">«The Baltic Course» Is Sold and Stays in Business!</a><br clear="all">This is it, my friends! It happened! We finally found someone willing to take over and continue our business. In the year of our 25th anniversary, in June – precisely the month the first ever issue of The Baltic Course was released, our media project has found its new owner.</div>
</div>		
<div class="calendar">
<form action="" enctype="multipart/form-data" name="fCalendar" id="fCalendar" method="get">
<h4>Calendar</h4>
<select onchange="return setDate(this);" id="dateMon"><option selected value="1643320800">January<option  value="1645999200">February<option  value="1648414800">March<option  value="1651093200">April<option  value="1653685200">May<option  value="1656363600">June<option  value="1658955600">July<option  value="1661634000">August<option  value="1664312400">September<option  value="1666904400">October<option  value="1669586400">November<option  value="1672178400">December</select>&nbsp;<select onchange="return setDate(this);" id="dateYear"><option  value="1577829600">2020<option  value="1609452000">2021<option selected value="1640988000">2022<option  value="1672524000">2023</select>
<div class="dates"><span>Mo</span><span>Tu</span><span>We</span><span>Th</span><span>Fr</span><span>St</span><span>Su</span><br clear="all"><i>27</i><i>28</i><i>29</i><i>30</i><i>31</i><b>1</b><b>2</b><br clear="all"><u>3</u><u>4</u><u>5</u><u>6</u><u>7</u><b>8</b><b>9</b><br clear="all"><u>10</u><u>11</u><u>12</u><u>13</u><u>14</u><b>15</b><b>16</b><br clear="all"><u>17</u><u>18</u><u>19</u><u>20</u><u>21</u><b>22</b><b>23</b><br clear="all"><u>24</u><u>25</u><u>26</u><u>27</u><a href="/eng/?date=1643320800"><span>28</span></a><b>29</b><b>30</b><br clear="all"><u>31</u><i>1</i><i>2</i><i>3</i><i>4</i><i>5</i><i>6</i><br clear="all"></div>
<SCRIPT LANGUAGE="JavaScript" TYPE="text/javascript">
<!--
function setDate($this) {
	document.forms['fCalendar'].dates.value = $this.value;
	document.forms['fCalendar'].submit();
	return false;
}
//-->
</SCRIPT>
<input type="hidden" name="dates" value="">
</form>
</div>		<?
/* xmlize() is by Hans Anderson, www.hansanderson.com/contact/
 *
 * Ye Ole "Feel Free To Use it However" License [PHP, BSD, GPL].
 * some code in xml_depth is based on code written by other PHPers
 * as well as one Perl script.  Poor programming practice and organization
 * on my part is to blame for the credit these people aren't receiving.
 * None of the code was copyrighted, though.
 *
 * This is a stable release, 1.0.  I don't foresee any changes, but you
 * might check http://www.hansanderson.com/php/xml/ to see
 *
 * usage: $xml = xmlize($xml_data);
 *
 * See the function traverse_xmlize() for information about the
 * structure of the array, it's much easier to explain by showing you.
 * Be aware that the array is very complex.  I use xmlize all the time,
 * but still need to use traverse_xmlize or print_r() quite often to
 * show me the structure!
 *
 */

class xmlBase {
	function xmlize($data, $WHITE=1) {

		$data = trim($data);
		$vals = $index = $array = array();
		$parser = xml_parser_create();
		xml_parser_set_option($parser, XML_OPTION_CASE_FOLDING, 0);
		xml_parser_set_option($parser, XML_OPTION_SKIP_WHITE, $WHITE);
		if ( !xml_parse_into_struct($parser, $data, $vals, $index) ) {
			die(sprintf("XML error: %s at line %d",
						xml_error_string(xml_get_error_code($parser)),
						xml_get_current_line_number($parser)));
		}
		xml_parser_free($parser);
	
		$i = 0; 
	
		$tagname = $vals[$i]['tag'];
		if ( isset ($vals[$i]['attributes'] ) )
		{
			$array[$tagname]['@'] = $vals[$i]['attributes'];
		} else {
			$array[$tagname]['@'] = array();
		}
	
		$array[$tagname]["#"] = $this->xml_depth($vals, $i);
	
		return $array;
	}

/* 
 *
 * You don't need to do anything with this function, it's called by
 * xmlize.  It's a recursive function, calling itself as it goes deeper
 * into the xml levels.  If you make any improvements, please let me know.
 *
 *
 */

	function xml_depth($vals, &$i) { 
		$children = array(); 
	
		if ( isset($vals[$i]['value']) )
		{
			array_push($children, $vals[$i]['value']);
		}
	
		while (++$i < count($vals)) { 
	
			switch ($vals[$i]['type']) { 
	
			   case 'open': 
	
					if ( isset ( $vals[$i]['tag'] ) )
					{
						$tagname = $vals[$i]['tag'];
					} else {
						$tagname = '';
					}
	
					if ( isset ( $children[$tagname] ) )
					{
						$size = sizeof($children[$tagname]);
					} else {
						$size = 0;
					}
	
					if ( isset ( $vals[$i]['attributes'] ) ) {
						$children[$tagname][$size]['@'] = $vals[$i]["attributes"];
					}
	
					$children[$tagname][$size]['#'] = $this->xml_depth($vals, $i);
	
				break; 
	
	
				case 'cdata':
					array_push($children, $vals[$i]['value']); 
				break; 
	
				case 'complete': 
					$tagname = $vals[$i]['tag'];
	
					if( isset ($children[$tagname]) )
					{
						$size = sizeof($children[$tagname]);
					} else {
						$size = 0;
					}
	
					if( isset ( $vals[$i]['value'] ) )
					{
						$children[$tagname][$size]["#"] = $vals[$i]['value'];
					} else {
						$children[$tagname][$size]["#"] = '';
					}
	
					if ( isset ($vals[$i]['attributes']) ) {
						$children[$tagname][$size]['@']
												 = $vals[$i]['attributes'];
					}
	
				break; 
	
				case 'close':
					return $children; 
				break;
			} 
	
		} 
		return $children;
	}


/* function by acebone@f2s.com, a HUGE help!
 *
 * this helps you understand the structure of the array xmlize() outputs
 *
 * usage:
 * traverse_xmlize($xml, 'xml_');
 * print '<pre>' . implode("", $traverse_array . '</pre>';
 *
 *
 */ 

	function traverse_xmlize($array, $arrName = "array", $level = 0) {
		foreach($array as $key=>$val) {
			if ( is_array($val) ) {
				$this->traverse_xmlize($val, $arrName . "[" . $key . "]", $level + 1);
			} else {
				$GLOBALS['traverse_array'][] = '$' . $arrName . '[' . $key . '] = "' . $val . "\"\n";
			}
		}
	
		return 1;
	
	}
}
?>
